Jump to content

CH Flight Sim Yoke Issue


Recommended Posts

Good Morning Guys.

 

Im having an issue with my Yoke (CH Products). The Elevator Axis is malfunctioning, I tried calibrating it with out possitive results. I crash everytime I land, sometimes it responds and sometimes it doesnt. Im fyling FSX Steam. Any help would be Appreciated

 

Thnx

 

Oscar

Link to comment
Share on other sites

I has this issue last year. I opened the casing and sprayed a very small amount of WD40 on the potentiometers (electrical contacts) inside, and I also replaced the metal springs with rubber bands as shown in the video on this website: https://www.rogerdodger.net/hacks-and-mods/ch-products-yoke-modification/

Tim Wright "The older I get, the better I was..."

Xbox Series X, Gigabyte Aorus GA-Z270X-Gaming 7, Intel i5-7600k 3.80GHz, NZXT X62 Kraken, 32Gb Corsair DDR4 3000, 2x 2TB Samsung Hybrid SSD's

LG DVDRW, NVidia RTX2060 6Gb, Logitech Yoke System, CH Pro Pedals, Acer K272HL 27", Win 10 Pro x64

Link to comment
Share on other sites

For those type of repairs I would use contact spray instead of wd-40.

 

Contact spray is non-conductive, so it can't crate short circuits.

It also does not affect rubber or plastic.

 

https://www.griffon.eu/en/product.946.contact-spray

 

 

 

I don't know the CH product very well. There are a lot of threads on this forum from people that have an issue with calibration.

Or an issue with using the CH product while they also haver another controller attched. For example an old joystick or Xbox controller.

So first of all I would test with just the CH controller attached. No other usb devisces.

That way you can check it is not one of those issues.

Edited by il88pp
[sIGPIC][/sIGPIC]
Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...