Jump to content

Need help balancing analog linear slide poteniometer values for TPM controls


Sea2Sky
 Share

Recommended Posts

I've been building some sim TPM controls using actual Cessna TPM controls, but mounting a linear slide potentiometer where the cable goes.

 

I have the throttle control working, but notice that the range from one end to the other is not balanced. When the throttle is off, its value is jittering between 3-5. Approximately 25% throttle on the slide pot shows a high jitter value at 976-978, 50% value at 1006-1007, 75% value at 1014-105, and 100% value at 1018-1019.

 

Flight Illusion GSA-010 I/O board. The software has range limit input from 0-1023, with a cross over value setting. Changing the cross over value doesn't make any difference. The issue looks like it's coming from the the analog signal.

 

Has anyone else had this same issue, and were they able to overcome it? I tried using both 20k and 50k linear slide pots. Am I using defective pot slides?

 

Capture.PNG

Link to comment
Share on other sites

The elaborate a little more, I've tested the slide potentiometer with 20k resistance, and they are indeed linear based on the resistance value.

 

When I wire them up, it's still doing about 90% value reading at 25% slide increase. Even though the slide pots ere tested correctly, I've tried using a few other slide pots with the same results.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...