Jump to content

Plane doesnt follow autopilot


Recommended Posts

I have had the sim about a week now, everything seemed to be working ok big learning curve. This morning I took off in a cesna jet from Las Vegas to Grand Canyon, set up my autopilot and took off, turned on autopilot but does not follow the autopilot settings for altitude and vertical speed. It will climb wildly up and then wildly down, ignoring VS and altitude settings in the autopilot. Any ideas?
Link to comment
Share on other sites

From what I understand when you have the autopilot on and you press ALT it holds the current attitude. I can climb using the vertical speed wheel - decrease vertical speed/increase vertical speed - to set a 500 fpm climb.

I'm having some problems descending while on autopilot. Once I've pressed the ALT button the autopilot seems to want to hold at that altitude and won't allow me to descend. I end up having the AI co-pilot land the plane.

Link to comment
Share on other sites

  • 4 weeks later...
There are shorter videos but in the end occasionally the AP will decide to kill you even after you switch it off.

 

^^^ THIS! ^^^

I was flying the King Air 350 Saturday on a short hop from Santa Barbara over to Los Angeles when I got the sudden urge to go make myself a quick coffee (sadly no flight attendant service on this trip).

 

My plan was to manual fly the route being that it's so short n'all... But figured I'd go ahead, set my relative heading to LA, kick on the Auto pilot, and select the altitude hold @ 13000ft. (yes, lucky #13... in hindsight probably not the wisest of decisions).

 

Anyhow... So I got the AP configured and confirmed the altitude and track were holding as expected and headed off to the kitchen for that much needed coffee.

 

Well no sooner am I out in the kitchen poring the hot water when I hear a faint autopilot disconnect sound off in the distance... Of course at that point I was in denial thinking "that surely couldn't have been MY autopilot?" --As if there was any other autopilot operating in the vicinity of my home--:rolleyes:

 

So I wandered back to the captain's seat with delicious coffee in hand only to find that my beautiful King Air 350 was now resting in the middle of Ventura Harbor! :(

 

 

Moral of this story... DO NOT TRUST THE AUTOPILOT !!!

 

.... And for god's sake, stop being so cheap & just hire a darn flight attendant! ;););)

Link to comment
Share on other sites

Most probably you have ALT autopilot in FLC (flight level change) in this mode, the autopilot uses the highest VS possible according to your speed/throttle configuration or your fmc.

 

If you have speed or power it will climb fast. Its also usually linked to the flightplan waypoints in FMS, meaning if your waypoint has a speed of 280 kts and you set to climb level change it will climb at a VS that allows it to maintain speed of 280kts

 

If you want to control the fpm you must change the altitude mode to VS, i dont know where you do that in the Citation cause i dont fly it and every plane is diferent, but it shouldnt be hard its there in autopilot panel somewhere

Edited by Kapitan

Kapitan

Anything I say is...not as serious as you think

Link to comment
Share on other sites

I can work around the AP shortcomings but sometimes things just break and the AP will try to turn in a heading and/or reach an altitude even though you have switched it off and have taken manual control for landing.

 

It doesn’t happen often but it happened to me yesterday. Switched the AP off to enter landing pattern and the plane consistently fought to bank left and high. Trimming the nose hard down could break the climb and repeatedly turning the AP on and off eventually broke the turn.

 

It seemed like that if you use NAV and have a desired altitude set but later use Heading Mode and VS, switching the AP off has the effect of telling the AP to chase the original settings despite the AP being turned off. And it was, without any doubt, turned off. According to both the Garmin and the button mouseover tip.

 

It doesn’t happen to me often but it happens. My intuition is that the problem has gotten a lot worse since they ‘fixed’ the issue in the last patch.

Link to comment
Share on other sites

My theory is that the stability scalars are too low in the flight_model.cfg files of every aircraft that has one (the deluxe aircraft don't).

Some have their stability settings as low as 0.1, that's just 10%, and I don't think the autopilot can handle that in turbulence or higher crosswinds.

In previous sims, the stability settings have always been 1.0, or 100%.

I've re-set all my stability scalars to 1, or 100%, and the autopilots are totally reliable.

The scalars I'm referring to are in the flight_model.cfg under the [FLIGHT_TUNING] heading:

 

pitch_stability = 1

roll_stability = 1

yaw_stability = 1

 

Changing these settings has no effect on how the planes fly, they don't handle as if they're 'on rails', and they still get bounced around in turbulence.

Edited by tiger1962

Tim Wright "The older I get, the better I was..."

Xbox Series X, Gigabyte Aorus GA-Z270X-Gaming 7, Intel i5-7600k 3.80GHz, NZXT X62 Kraken, 32Gb Corsair DDR4 3000, 2x 2TB Samsung Hybrid SSD's

LG DVDRW, NVidia RTX2060 6Gb, Logitech Yoke System, CH Pro Pedals, Acer K272HL 27", Win 10 Pro x64

Link to comment
Share on other sites

My theory is that the stability scalars are too low in the flight_model.cfg files of every aircraft that has one (the deluxe aircraft don't).

Some have their stability settings as low as 0.1, that's just 10%, and I don't think the autopilot can handle that in turbulence or higher crosswinds.

In previous sims, the stability settings have always been 1.0, or 100%.

I've re-set all my stability scalars to 1, or 100%, and the autopilots are totally reliable.

The scalars I'm referring to are in the flight_model.cfg under the [FLIGHT_TUNING] heading:

 

pitch_stability = 1

roll_stability = 1

yaw_stability = 1

 

Changing these settings has no effect on how the planes fly, they don't handle as if they're 'on rails', and they still get bounced around in turbulence.

 

Where can I find these settings?

Link to comment
Share on other sites

Where can I find these settings?

 

Oops! Sorry for not mentioning that (and the late reply), the aircraft folders are in:

 

C:\Users\yourname\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\Packages\Official\OneStore

Tim Wright "The older I get, the better I was..."

Xbox Series X, Gigabyte Aorus GA-Z270X-Gaming 7, Intel i5-7600k 3.80GHz, NZXT X62 Kraken, 32Gb Corsair DDR4 3000, 2x 2TB Samsung Hybrid SSD's

LG DVDRW, NVidia RTX2060 6Gb, Logitech Yoke System, CH Pro Pedals, Acer K272HL 27", Win 10 Pro x64

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...